use strict;
my $str = '<p>Create a new line</p>
create a new line
To create a
To Create a
recreate a new
Recreate a new
To recreate a new
to be created
to create
<img src="test_create_a.gif">
<img src="test_recreated_a.gif">
Created by me
4.8.1 Create a Cross-Reference (within a Topic)';
my $regex = qr/(?<!<[^>]*)create/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}