re = /(?<!<[^>]*)create/mi
str = '<p>Create a new line</p>
create a new line
To create a
To Create a
recreate a new
Recreate a new
To recreate a new
to be created
to create
<img src="test_create_a.gif">
<img src="test_recreated_a.gif">
Created by me
4.8.1 Create a Cross-Reference (within a Topic)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end