import re
regex = re.compile(r"(?<!<[^>]*)create", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<p>Create a new line</p>\n"
"create a new line\n"
"To create a \n"
"To Create a\n"
"recreate a new\n"
"Recreate a new\n"
"To recreate a new \n"
"to be created\n"
"to create\n"
"<img src=\"test_create_a.gif\">\n"
"<img src=\"test_recreated_a.gif\">\n"
" Created by me\n"
"4.8.1 Create a Cross-Reference (within a Topic)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")