re = /^(?=.*[a-z].*)(?=.*[A-Z].*)(?=.*[0-9].*)[a-zA-Z0-9]{6,32}$/m
str = 'Deve conter pelo menos uma letra maiúscula.
Pelo menos uma minúscula
Pelo menos um número
O tamanho deve estar entre 6 e 32 caracteres
Não pode ter nenhum carácter especial ou espaço
Deve ter todos os 3 tipos: maiúsculas, minúsculas e números, não importa a ordem
Match:
Mm01234
mM01234
01M23m4
Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1
Invalidar:
Mm.0123
Mmmmmmm
m012345
M012345
0123456
MMMMMMM
Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end