using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\.]+)(?!.*\1)";
string input = @"H. Gerhardstraat 77 1502 CC 77 1502 CC Zaandam
How are are you
I I I am fine";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}