$re = '/([\w\.]+)(?!.*\1)/m';
$str = 'H. Gerhardstraat 77 1502 CC 77 1502 CC Zaandam
How are are you
I I I am fine';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);