const regex = new RegExp('([\\w\\.]+)(?!.*\\1)', 'gm')
const str = `H. Gerhardstraat 77 1502 CC 77 1502 CC Zaandam
How are are you
I I I am fine`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}