#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<h.>.+?)\s+((\S|<[^>]+>)*)\n|$"
Local $sString = "<h2>This is a test heading</h2>" & @CRLF & _
"<p>Here is some text</p>" & @CRLF & _
"<div>" & @CRLF & _
" <h3>Here is a another heading</h3>" & @CRLF & _
" <p>Some more paragraph text which shouldn't match</p>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")