const regex = /(<h.>.+?)\s+((\S|<[^>]+>)*)\n|$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<h.>.+?)\\s+((\\S|<[^>]+>)*)\\n|$', 'gi')
const str = `<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}