re = /(<h.>.+?)\s+((\S|<[^>]+>)*)\n|$/i
str = '<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn\'t match</p>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end