import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<h.>.+?)\\s+((\\S|<[^>]+>)*)\\n|$";
final String string = "<h2>This is a test heading</h2>\n"
+ "<p>Here is some text</p>\n"
+ "<div>\n"
+ " <h3>Here is a another heading</h3>\n"
+ " <p>Some more paragraph text which shouldn't match</p>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}