const regex = /[MS]NP\s*-?\d+(?:\.\d+)?\s*%/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[MS]NP\\s*-?\\d+(?:\\.\\d+)?\\s*%', 'gm')
const str = `abcd efghMNP 0.40 % ijkl mnopSNP -3.20 % xyz`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);