re = /[MS]NP\s*-?\d+(?:\.\d+)?\s*%/m
str = 'abcd efghMNP 0.40 % ijkl mnopSNP -3.20 % xyz'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result