// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[MS]NP\s*-?\d+(?:\.\d+)?\s*%").unwrap();
let string = "abcd efghMNP 0.40 % ijkl mnopSNP -3.20 % xyz";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}