use strict;
my $str = 'abcd efghMNP 0.40 % ijkl mnopSNP -3.20 % xyz';
my $regex = qr/[MS]NP\s*-?\d+(?:\.\d+)?\s*%/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";