# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\D)(\d)(?=\.)/0\1/gmi;t' <<< "27.6.2024 21:02:32
29.6.2024 21:02:32
4.7.2024 21:02:32
"