using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\D)(\d)(?=\.)";
string substitution = @"0\1";
string input = @"27.6.2024 21:02:32
29.6.2024 21:02:32
4.7.2024 21:02:32
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}