# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\D)(\d)(?=\.)"
test_str = ("27.6.2024 21:02:32\n"
"29.6.2024 21:02:32\n"
"4.7.2024 21:02:32\n")
subst = "0\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.