import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\D)(\\d)(?=\\.)";
final String string = "27.6.2024 21:02:32\n"
+ "29.6.2024 21:02:32\n"
+ "4.7.2024 21:02:32\n";
final String subst = "0\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}