# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d) +(?=G)//gm;t' <<< "XXX YYY AAA 16Gb 16 Gb 16 G 2 G ZZZ"