using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d) +(?=G)";
string substitution = @"";
string input = @"XXX YYY AAA 16Gb 16 Gb 16 G 2 G ZZZ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}