import Foundation
let pattern = #"(?<=\d) +(?=G)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"XXX YYY AAA 16Gb 16 Gb 16 G 2 G ZZZ"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)