use strict;
my $str = 'XXX YYY AAA 16Gb 16 Gb 16 G 2 G ZZZ';
my $regex = qr/(?<=\d) +(?=G)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";