#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(dateAdded:\s\/Date\()\d+\)\/\}\]"
Local $sString = "MULTIVALUE FIELD "APPID" -first event apps: [ [-] { [-] addedById: 5d013c468 appId: 5d0d1fc13d418bdf5 dateAdded: /Date(1573503009489)/ MULTIVALUE FIELD APPID-last value which needs to be extracted addedById: 398 appId:ccaaadb dateAdded: /Date(1584128055615)/}]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")