re = /(dateAdded:\s\/Date\()\d+\)\/\}\]/m
str = 'MULTIVALUE FIELD "APPID" -first event apps: [ [-] { [-] addedById: 5d013c468 appId: 5d0d1fc13d418bdf5 dateAdded: /Date(1573503009489)/ MULTIVALUE FIELD APPID-last value which needs to be extracted addedById: 398 appId:ccaaadb dateAdded: /Date(1584128055615)/}]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end