// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(dateAdded:\s\/Date\()\d+\)\/\}\]").unwrap();
let string = "MULTIVALUE FIELD \"APPID\" -first event apps: [ [-] { [-] addedById: 5d013c468 appId: 5d0d1fc13d418bdf5 dateAdded: /Date(1573503009489)/ MULTIVALUE FIELD APPID-last value which needs to be extracted addedById: 398 appId:ccaaadb dateAdded: /Date(1584128055615)/}]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}