const regex = /(dateAdded:\s\/Date\()\d+\)\/\}\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(dateAdded:\\s\\\/Date\\()\\d+\\)\\\/\\}\\]', 'gm')
const str = `MULTIVALUE FIELD "APPID" -first event apps: [ [-] { [-] addedById: 5d013c468 appId: 5d0d1fc13d418bdf5 dateAdded: /Date(1573503009489)/ MULTIVALUE FIELD APPID-last value which needs to be extracted addedById: 398 appId:ccaaadb dateAdded: /Date(1584128055615)/}]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}