package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)# Match vertical grid.
(\|) (?= \s+ .+ \| \s* $ | $)
|
# Match header colon.
(
(?<= \| \s )
:
|
:
(?= \s \| )
)
|
# Match horizontal grid.
(?<= \| \s | \ | \s : )
(-+)
(?= :? \s \| )
`)
var str = `# Match
| Time | Block |
| ----------: | :---------------- |
| (00:00) | (Revision #1) |
| | |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| 00:00-00:00 | Some meeting |
| 11:00-13:00 | Chunk |
| | - Note w/ details |
| | |
| (00:00) | (Revision #1) |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| Tracker | Task | Backlog |
| ----------: | :------------- | :------------ |
| 00:00-00:00 | [x] Task one | [[wiki.link |
| 00:00-00:00 | | |
| 0m | | |
| | | |
| | [<] Task two | [[wiki.link]] |
| | [<] Task three | [[wiki.link]] |
| Column 1 | Column 2 |
| :------: | :------: |
| (1, 1) | (1, 2) |
| (2, 1) | (2, 2) |
| (3, 1) | (3, 2) |
# Do not match.
Some pipes | do match | I wonder why | hmm?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}