import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Match vertical grid.\n"
+ "(\\|) (?= \\s+ .+ \\| \\s* $ | $)\n"
+ "|\n\n"
+ "# Match header colon.\n"
+ "(\n"
+ " (?<= \\| \\s )\n"
+ " :\n"
+ " |\n"
+ " :\n"
+ " (?= \\s \\| )\n"
+ ")\n"
+ "|\n\n"
+ "# Match horizontal grid.\n"
+ "(?<= \\| \\s | \\ | \\s : )\n"
+ " (-+)\n"
+ "(?= :? \\s \\| )\n";
final String string = "# Match\n\n"
+ "| Time | Block |\n"
+ "| ----------: | :---------------- |\n"
+ "| (00:00) | (Revision #1) |\n"
+ "| | |\n"
+ "| 00:00-00:00 | Chunk |\n"
+ "| | - Note w/ details |\n"
+ "| 00:00-00:00 | Some meeting |\n"
+ "| 11:00-13:00 | Chunk |\n"
+ "| | - Note w/ details |\n"
+ "| | |\n"
+ "| (00:00) | (Revision #1) |\n"
+ "| 00:00-00:00 | Chunk |\n"
+ "| | - Note w/ details |\n\n"
+ "| Tracker | Task | Backlog |\n"
+ "| ----------: | :------------- | :------------ |\n"
+ "| 00:00-00:00 | [x] Task one | [[wiki.link |\n"
+ "| 00:00-00:00 | | | \n"
+ "| 0m | | |\n"
+ "| | | |\n"
+ "| | [<] Task two | [[wiki.link]] |\n"
+ "| | [<] Task three | [[wiki.link]] |\n\n"
+ " | Column 1 | Column 2 |\n"
+ " | :------: | :------: |\n"
+ " | (1, 1) | (1, 2) |\n"
+ " | (2, 1) | (2, 2) |\n"
+ " | (3, 1) | (3, 2) |\n\n"
+ "# Do not match.\n\n"
+ "Some pipes | do match | I wonder why | hmm?";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}