const regex = /# Match vertical grid.
(\|) (?= \s+ .+ \| \s* $ | $)
|
# Match header colon.
(
(?<= \| \s )
:
|
:
(?= \s \| )
)
|
# Match horizontal grid.
(?<= \| \s | \ | \s : )
(-+)
(?= :? \s \| )
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# Match vertical grid.
(\\|) (?= \\s+ .+ \\| \\s* $ | $)
|
# Match header colon.
(
(?<= \\| \\s )
:
|
:
(?= \\s \\| )
)
|
# Match horizontal grid.
(?<= \\| \\s | \\ | \\s : )
(-+)
(?= :? \\s \\| )
', 'gm')
const str = `# Match
| Time | Block |
| ----------: | :---------------- |
| (00:00) | (Revision #1) |
| | |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| 00:00-00:00 | Some meeting |
| 11:00-13:00 | Chunk |
| | - Note w/ details |
| | |
| (00:00) | (Revision #1) |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| Tracker | Task | Backlog |
| ----------: | :------------- | :------------ |
| 00:00-00:00 | [x] Task one | [[wiki.link |
| 00:00-00:00 | | |
| 0m | | |
| | | |
| | [<] Task two | [[wiki.link]] |
| | [<] Task three | [[wiki.link]] |
| Column 1 | Column 2 |
| :------: | :------: |
| (1, 1) | (1, 2) |
| (2, 1) | (2, 2) |
| (3, 1) | (3, 2) |
# Do not match.
Some pipes | do match | I wonder why | hmm?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}