$re = '/# Match vertical grid.
(\|) (?= \s+ .+ \| \s* $ | $)
|
# Match header colon.
(
(?<= \| \s )
:
|
:
(?= \s \| )
)
|
# Match horizontal grid.
(?<= \| \s | \ | \s : )
(-+)
(?= :? \s \| )
/xm';
$str = '# Match
| Time | Block |
| ----------: | :---------------- |
| (00:00) | (Revision #1) |
| | |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| 00:00-00:00 | Some meeting |
| 11:00-13:00 | Chunk |
| | - Note w/ details |
| | |
| (00:00) | (Revision #1) |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| Tracker | Task | Backlog |
| ----------: | :------------- | :------------ |
| 00:00-00:00 | [x] Task one | [[wiki.link |
| 00:00-00:00 | | |
| 0m | | |
| | | |
| | [<] Task two | [[wiki.link]] |
| | [<] Task three | [[wiki.link]] |
| Column 1 | Column 2 |
| :------: | :------: |
| (1, 1) | (1, 2) |
| (2, 1) | (2, 2) |
| (3, 1) | (3, 2) |
# Do not match.
Some pipes | do match | I wonder why | hmm?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);