#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=src=").*?\.(?:gif|jp[e]?g|png)"
Local $sString = " <p><img src="maquette_kuthawdaw.png" width="907"></p>" & @CRLF & _
" <p class="centered"><img src="photos/2019-11-28/large/20191128_095919_GM.bmp" width="49%"> " & @CRLF & _
" <img src="photos/2019-11-28/large/20191128_100050_GM.jpg" width="49%"></p>" & @CRLF & _
" <p class="centered"><img src="photos/2019-11-28/large/2019112#_101710_GM.jpg" width="49%"> " & @CRLF & _
" <img src="photos/2019-11-28/large/20191128_101541_GM.jpg" width="49%"></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")