using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=src="").*?\.(?:gif|jp[e]?g|png)";
string input = @" <p><img src=""maquette_kuthawdaw.png"" width=""907""></p>
<p class=""centered""><img src=""photos/2019-11-28/large/20191128_095919_GM.bmp"" width=""49%"">
<img src=""photos/2019-11-28/large/20191128_100050_GM.jpg"" width=""49%""></p>
<p class=""centered""><img src=""photos/2019-11-28/large/2019112#_101710_GM.jpg"" width=""49%"">
<img src=""photos/2019-11-28/large/20191128_101541_GM.jpg"" width=""49%""></p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}