use strict;
my $str = ' <p><img src="maquette_kuthawdaw.png" width="907"></p>
<p class="centered"><img src="photos/2019-11-28/large/20191128_095919_GM.bmp" width="49%">
<img src="photos/2019-11-28/large/20191128_100050_GM.jpg" width="49%"></p>
<p class="centered"><img src="photos/2019-11-28/large/2019112#_101710_GM.jpg" width="49%">
<img src="photos/2019-11-28/large/20191128_101541_GM.jpg" width="49%"></p>';
my $regex = qr/(?<=src=").*?\.(?:gif|jp[e]?g|png)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}