import Foundation
let pattern = #"(?<=src=").*?\.(?:gif|jp[e]?g|png)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<p><img src="maquette_kuthawdaw.png" width="907"></p>
<p class="centered"><img src="photos/2019-11-28/large/20191128_095919_GM.bmp" width="49%">
<img src="photos/2019-11-28/large/20191128_100050_GM.jpg" width="49%"></p>
<p class="centered"><img src="photos/2019-11-28/large/2019112#_101710_GM.jpg" width="49%">
<img src="photos/2019-11-28/large/20191128_101541_GM.jpg" width="49%"></p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)