#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[\r\n]+((\d{2}).(\d{2}).(\d{4}) (\d{2}):(\d{2}):(\d{2})))?;([;]{1})"
Local $sString = "23.05.2022 05:59:00;1;;;;;;;;;" & @CRLF & _
"23.05.2022 05:59:00;;2;;;;;;;;" & @CRLF & _
"23.05.2022 05:59:00;;;3;;;;;;;" & @CRLF & _
"23.05.2022 05:59:00;;;;4;;;;;;" & @CRLF & _
"23.05.2022 05:59:00;;;;;5;;;;;" & @CRLF & _
"23.05.2022 05:59:00;;;;;;6;;;;" & @CRLF & _
"23.05.2022 05:59:00;;;;;;;7;;;" & @CRLF & _
"23.05.2022 05:59:00;;;;;;;;8;;" & @CRLF & _
"23.05.2022 05:59:00;;;;;;;;;9;" & @CRLF & _
"23.05.2022 05:59:00;;;;;;;;;;10" & @CRLF & _
"23.05.2022 06:59:00;1;;;;;;;;;" & @CRLF & _
"23.05.2022 06:59:00;;2;;;;;;;;" & @CRLF & _
"23.05.2022 06:59:00;;;3;;;;;;;" & @CRLF & _
"23.05.2022 06:59:00;;;;4;;;;;;" & @CRLF & _
"23.05.2022 06:59:00;;;;;5;;;;;" & @CRLF & _
"23.05.2022 06:59:00;;;;;;6;;;;" & @CRLF & _
"23.05.2022 06:59:00;;;;;;;7;;;" & @CRLF & _
"23.05.2022 06:59:00;;;;;;;;8;;" & @CRLF & _
"23.05.2022 06:59:00;;;;;;;;;9;" & @CRLF & _
"23.05.2022 06:59:00;;;;;;;;;;10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")