use strict;
my $str = '23.05.2022 05:59:00;1;;;;;;;;;
23.05.2022 05:59:00;;2;;;;;;;;
23.05.2022 05:59:00;;;3;;;;;;;
23.05.2022 05:59:00;;;;4;;;;;;
23.05.2022 05:59:00;;;;;5;;;;;
23.05.2022 05:59:00;;;;;;6;;;;
23.05.2022 05:59:00;;;;;;;7;;;
23.05.2022 05:59:00;;;;;;;;8;;
23.05.2022 05:59:00;;;;;;;;;9;
23.05.2022 05:59:00;;;;;;;;;;10
23.05.2022 06:59:00;1;;;;;;;;;
23.05.2022 06:59:00;;2;;;;;;;;
23.05.2022 06:59:00;;;3;;;;;;;
23.05.2022 06:59:00;;;;4;;;;;;
23.05.2022 06:59:00;;;;;5;;;;;
23.05.2022 06:59:00;;;;;;6;;;;
23.05.2022 06:59:00;;;;;;;7;;;
23.05.2022 06:59:00;;;;;;;;8;;
23.05.2022 06:59:00;;;;;;;;;9;
23.05.2022 06:59:00;;;;;;;;;;10';
my $regex = qr/(?:[\r\n]+((\d{2}).(\d{2}).(\d{4}) (\d{2}):(\d{2}):(\d{2})))?;([;]{1})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}