// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[\r\n]+((\d{2}).(\d{2}).(\d{4}) (\d{2}):(\d{2}):(\d{2})))?;([;]{1})").unwrap();
let string = "23.05.2022 05:59:00;1;;;;;;;;;
23.05.2022 05:59:00;;2;;;;;;;;
23.05.2022 05:59:00;;;3;;;;;;;
23.05.2022 05:59:00;;;;4;;;;;;
23.05.2022 05:59:00;;;;;5;;;;;
23.05.2022 05:59:00;;;;;;6;;;;
23.05.2022 05:59:00;;;;;;;7;;;
23.05.2022 05:59:00;;;;;;;;8;;
23.05.2022 05:59:00;;;;;;;;;9;
23.05.2022 05:59:00;;;;;;;;;;10
23.05.2022 06:59:00;1;;;;;;;;;
23.05.2022 06:59:00;;2;;;;;;;;
23.05.2022 06:59:00;;;3;;;;;;;
23.05.2022 06:59:00;;;;4;;;;;;
23.05.2022 06:59:00;;;;;5;;;;;
23.05.2022 06:59:00;;;;;;6;;;;
23.05.2022 06:59:00;;;;;;;7;;;
23.05.2022 06:59:00;;;;;;;;8;;
23.05.2022 06:59:00;;;;;;;;;9;
23.05.2022 06:59:00;;;;;;;;;;10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}