import Foundation
let pattern = #"(?:[\r\n]+((\d{2}).(\d{2}).(\d{4}) (\d{2}):(\d{2}):(\d{2})))?;([;]{1})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
23.05.2022 05:59:00;1;;;;;;;;;
23.05.2022 05:59:00;;2;;;;;;;;
23.05.2022 05:59:00;;;3;;;;;;;
23.05.2022 05:59:00;;;;4;;;;;;
23.05.2022 05:59:00;;;;;5;;;;;
23.05.2022 05:59:00;;;;;;6;;;;
23.05.2022 05:59:00;;;;;;;7;;;
23.05.2022 05:59:00;;;;;;;;8;;
23.05.2022 05:59:00;;;;;;;;;9;
23.05.2022 05:59:00;;;;;;;;;;10
23.05.2022 06:59:00;1;;;;;;;;;
23.05.2022 06:59:00;;2;;;;;;;;
23.05.2022 06:59:00;;;3;;;;;;;
23.05.2022 06:59:00;;;;4;;;;;;
23.05.2022 06:59:00;;;;;5;;;;;
23.05.2022 06:59:00;;;;;;6;;;;
23.05.2022 06:59:00;;;;;;;7;;;
23.05.2022 06:59:00;;;;;;;;8;;
23.05.2022 06:59:00;;;;;;;;;9;
23.05.2022 06:59:00;;;;;;;;;;10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)