#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(\bclass)(?:[:]([_a-zA-Z0-9-]+))?\s*[=]?(?:[{}]{0,}['"\s]*\b(.+)?\b["'\s]*[{}]*)?)|(?:\B([@]apply)\s+([_a-zA-Z0-9-\s\:\/]*)[;]?)"
Local $sString = "<SvelteComponent class:active={true} />" & @CRLF & _
"<img src="..." class="image" />" & @CRLF & _
"<div class="@apply bg-gray-500 px-10 py-5;">" & @CRLF & _
"class:active={is_active ? true : false}" & @CRLF & _
"class="mb-0 font-semibold text-white" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")