using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\bclass)(?:[:]([_a-zA-Z0-9-]+))?\s*[=]?(?:[{}]{0,}['""\s]*\b(.+)?\b[""'\s]*[{}]*)?)|(?:\B([@]apply)\s+([_a-zA-Z0-9-\s\:\/]*)[;]?)";
string input = @"<SvelteComponent class:active={true} />
<img src=""..."" class=""image"" />
<div class=""@apply bg-gray-500 px-10 py-5;"">
class:active={is_active ? true : false}
class=""mb-0 font-semibold text-white"" ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}