import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\bclass)(?:[:]([_a-zA-Z0-9-]+))?\\s*[=]?(?:[\\{\\}]{0,}['\"\\s]*\\b(.+)?\\b[\"'\\s]*[\\{\\}]*)?)|(?:\\B([@]apply)\\s+([_a-zA-Z0-9-\\s\\:\\/]*)[;]?)";
final String string = "<SvelteComponent class:active={true} />\n"
+ "<img src=\"...\" class=\"image\" />\n"
+ "<div class=\"@apply bg-gray-500 px-10 py-5;\">\n"
+ "class:active={is_active ? true : false}\n"
+ "class=\"mb-0 font-semibold text-white\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}