const regex = /(?:(\bclass)(?:[:]([_a-zA-Z0-9-]+))?\s*[=]?(?:[{}]{0,}['"\s]*\b(.+)?\b["'\s]*[{}]*)?)|(?:\B([@]apply)\s+([_a-zA-Z0-9-\s\:\/]*)[;]?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\bclass)(?:[:]([_a-zA-Z0-9-]+))?\\s*[=]?(?:[{}]{0,}[\'"\\s]*\\b(.+)?\\b["\'\\s]*[{}]*)?)|(?:\\B([@]apply)\\s+([_a-zA-Z0-9-\\s\\:\\\/]*)[;]?)', 'gm')
const str = `<SvelteComponent class:active={true} />
<img src="..." class="image" />
<div class="@apply bg-gray-500 px-10 py-5;">
class:active={is_active ? true : false}
class="mb-0 font-semibold text-white" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}