import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?s).*EventCode=4688*.)((?si).*(%%1936|%%1938TokenElevationTypeDefault|TokenElevationTypeLimited))\n";
final String string = "A new process has been created.\n\n"
+ "Creator Subject:\n"
+ " Security ID: SYSTEM\n"
+ " Account Name: RFSH$\n"
+ " Account Domain: LAB\n"
+ " Logon ID: 0x3E7\n"
+ " EventCode=4688\n"
+ "Target Subject:\n"
+ " Security ID: LAB\\rsmith\n"
+ " Account Name: rsmith\n"
+ " Account Domain: LAB\n"
+ " Logon ID: 0x2C9D82\n\n"
+ "Process Information:\n"
+ " New Process ID: 0x2e0e4\n"
+ " New Process Name: C:\\Windows\\System32\\RuntimeBroker.exe\n"
+ " Token Elevation Type: %%1936\n"
+ " Mandatory Label: Mandatory Label\\Medium Mandatory Level\n"
+ " Creator Process ID: 0x268\n"
+ " Creator Process Name: C:\\Windows\\System32\\svchost.exe\n"
+ " Process Command Line:\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}