import re
regex = re.compile((r"((?s).*EventCode=4688*.)((?si).*(%%1936|%%1938TokenElevationTypeDefault|TokenElevationTypeLimited))\n"), flags=re.MULTILINE)
test_str = ("A new process has been created.\n\n"
"Creator Subject:\n"
" Security ID: SYSTEM\n"
" Account Name: RFSH$\n"
" Account Domain: LAB\n"
" Logon ID: 0x3E7\n"
" EventCode=4688\n"
"Target Subject:\n"
" Security ID: LAB\\rsmith\n"
" Account Name: rsmith\n"
" Account Domain: LAB\n"
" Logon ID: 0x2C9D82\n\n"
"Process Information:\n"
" New Process ID: 0x2e0e4\n"
" New Process Name: C:\\Windows\\System32\\RuntimeBroker.exe\n"
" Token Elevation Type: %%1936\n"
" Mandatory Label: Mandatory Label\\Medium Mandatory Level\n"
" Creator Process ID: 0x268\n"
" Creator Process Name: C:\\Windows\\System32\\svchost.exe\n"
" Process Command Line:\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")