using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\*;.*)?(\*;.*?\+g.oma.sip-im)(?:.*?(,\*;.*))?";
string input = @"*;+g.oma.sip-im;explicit,*;+g.3gpp.cs-voice;require";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}