$re = '/(\*;.*)?(\*;.*?\+g.oma.sip-im)(?:.*?(,\*;.*))?/';
$str = '*;+g.oma.sip-im;explicit,*;+g.3gpp.cs-voice;require';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);