// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\*;.*)?(\*;.*?\+g.oma.sip-im)(?:.*?(,\*;.*))?").unwrap();
let string = "*;+g.oma.sip-im;explicit,*;+g.3gpp.cs-voice;require";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}