re = /(\*;.*)?(\*;.*?\+g.oma.sip-im)(?:.*?(,\*;.*))?/
str = '*;+g.oma.sip-im;explicit,*;+g.3gpp.cs-voice;require'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end