#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+) > проверить, что элемент коллекции \"(.+)\" коллекции под номером (\d+) находится в состоянии (доступен|не доступен)(?: для редактирования|)$"
Local $sString = "То Проблемы_ОбновлениеПолей > проверить, что элемент коллекции "Поле Статус" коллекции под номером 2 находится в состоянии не доступен для редактирования"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")